System Outage/Slowness - Ring Central outage

Incident Report for Forth™ CRM

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 11:37 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 08, 2025 - 19:10 CST

Investigating

We are currently investigating this issue.
Posted Feb 08, 2025 - 13:15 CST
This incident affected: Forth CRM (Core Platform, Search).