Elevated System Errors

Incident Report for Forth™ CRM

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 10:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 15:00 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 18, 2025 - 12:10 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2025 - 10:17 CDT

Investigating

We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 18, 2025 - 09:45 CDT
This incident affected: Forth CRM (Core Platform, Document Generation).