BlueRock Dialers are not running properly. We are working on a fix.
Incident Report for Forth™ CRM
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 09:08 CST
Investigating
We are currently investigating this issue.
Posted Nov 21, 2022 - 09:05 CST
This incident affected: Forth CRM (Core Platform).