We are still experiencing disruptions due to the AWS outage. Forth Credit is currently experiencing disruptions. We are currently investigating the extent of the impact and working to restore full functionality. We will provide updates as they become available.
Posted Oct 20, 2025 - 15:06 CDT
Update
We are still experiencing disruptions due to the AWS outage. Forth Credit is currently experiencing disruptions. We are currently investigating the extent of the impact and working to restore full functionality. We will provide updates as they become available.
Posted Oct 20, 2025 - 11:16 CDT
Update
Due to the AWS Outage, Forth Credit is experiencing disruptions. We are currently investigating the extent of the impact and working to restore full functionality. We will provide updates as they become available.
Posted Oct 20, 2025 - 09:36 CDT
Investigating
AWS outage is causing issues with system data not loading. This is also affecting MDC.
Posted Oct 20, 2025 - 08:27 CDT
This incident affected: Forth CRM (Core Platform) and Insights.