Credit Pull Issues

Incident Report for Forth™ CRM

Resolved

This incident has been resolved.
Posted Sep 14, 2022 - 15:11 CDT

Monitoring

Meridian Link/Universal Credit/Xactus have reported that credit pull processing times have significantly improved. Credit pulls through the CRM are now operational.

We will continue to monitor over the next few hours.
Posted Sep 14, 2022 - 12:01 CDT

Identified

Meridian Link/Universal Credit/Xactus is currently reporting system outages which is affecting the ability to pull credit in the CRM. We will continue to monitor the situation and update clients once they have fixed the issue.
Posted Sep 13, 2022 - 12:11 CDT
This incident affected: Forth CRM (Credit Pull).