System Slowness
Incident Report for Forth™ CRM
Resolved
This incident has been resolved.
Posted May 21, 2020 - 13:27 CDT
Monitoring
We've addressed the problem causing system slowness. We will continue to monitor throughout the day.
Posted May 21, 2020 - 12:45 CDT
Investigating
We are currently investigating this issue.
Posted May 21, 2020 - 12:42 CDT
This incident affected: Forth CRM (Core Platform).