Data sycning delayed

Incident Report for Forth CRM

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 16:21 CDT

Investigating

We are seeing delays with data syncing from our ETL provider. The issue has been reported and we are working to restore normal operations.
Posted Jul 20, 2026 - 13:33 CDT
This incident affected: Managed Data Cloud (Fivetran).