System Slowness

Incident Report for Forth™ CRM

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 15:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 12:01 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2025 - 12:01 CDT

Update

Our team is still actively working on this issue
Posted Apr 24, 2025 - 10:51 CDT

Update

We are continuing to investigate this issue and are working closely with our internal teams to identify the root cause. We remain committed to resolving this as quickly as possible and will share further updates as soon as they become available.
Posted Apr 24, 2025 - 10:50 CDT

Investigating

We are currently investigating this issue.
Posted Apr 24, 2025 - 09:25 CDT
This incident affected: Forth CRM (Core Platform, Search) and API (Forth CRM API, ForthPay API).