Data Sync Error; Fivetran outage

Incident Report for Forth™ CRM

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 09:21 CST

Monitoring

We are experiencing an interruption in data syncs caused by a Fivetran outage. The Fivetran team is investigating and working toward a resolution.
Posted Nov 06, 2025 - 21:25 CST
This incident affected: Forth CRM (Search) and Managed Data Cloud (Fivetran).