Email Error:
Incident Report for Forth™ CRM
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 10:49 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2024 - 10:48 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 25, 2024 - 10:46 CDT
Investigating
We are currently investigating this issue.
Posted Sep 24, 2024 - 16:22 CDT
This incident affected: Sengrid (SendGrid API v3, SendGrid SMTP).