System Slowness
Incident Report for Forth™ CRM
Resolved
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 15:43 CDT
Monitoring
We are continuing to monitor for any further issues.
Posted Oct 05, 2022 - 11:06 CDT
Investigating
We are currently investigating this issue.
Posted Oct 05, 2022 - 09:24 CDT
This incident affected: Forth CRM (Core Platform).